[linux-support] ASDL/LAN Schwierigkeiten

Theo Schmidt tschmidt at mus.ch
Mon Jan 5 21:11:06 CET 2004


Liebe Liste,
Ich bin fast am Ziel mit unserem LAN mit ADSL modem/router, aber 
schaffe den entscheidenden letzten Schritt nicht.

Ich habe:
1) funktionierendes Ethernet LAN mit Kombi-Gerät 
ADSL-Modem-Router-Switch Draytek2600We an dem 3 Linux PCs 
angeschlossen sind (1xSuSE8.1, 1xSuSE8.2, 1xDebian-Knoppix3.2). Das 
Gerät hat Adresse 192.168.1.1, die PCs 192.168.1.2, .3, und .4, 
Netzmaske 255.255.255.0

2) Funktionierendes Account von Tiscali

3) Funktionierende ADSL-Verbindung bis zum Router. Ich kann sie 
starten, stoppen, und die zugewiesene temporäre IP-Adresse sehen. 
Alles via Browser-Interface. Die Ports sind angegeben als: Telnet 23, 
HTTP 80, und FTP 21.

Aber, I kann kriege keine Verbindung zum Internet, weder über einen 
Browser wie Mozilla oder Konqueror, noch über Kmail: es kommt z.B. 
"unbekannter Rechner: xy", noch über ping (ausserhalb des LANs). Ping 
sagt: "Network is unreachable".

Auf www.adsl4linux.de gibt es ausführliche Anleitungen. Sie sagen: 
bei SuSE 8.1 ist der PPPoE im Kernel eingebaut und kann mit YaST 
konfiguriert werden. Es geht aber nicht, zwar keine Fehlermeldungen, 
aber auch keine Verbindung.

Die Howtos sagen weiter: wenn's nicht geht, manuell konfigurieren. Es 
folgt eine ziemlich komplizierte Anleitung, die mich überfordert, 
oder wenigstens, ich will dies vermeiden wenn es irgendwie geht. Für 
Debian gilt offenbar ohnehin nur die komplizierte Anleitung. Auf den 
adsl4linux Foren hat es eine ähnlich Frage wie meine, aber keine 
Antwort (ausser das Howto zu lesen).

Robert Jenni sagte mir, dass ich diese Sachen wahrscheinlich alle 
nicht brauche, sondern einfach für den Standard-Gateway bei jedem 
Rechner die IP-Adresse des Routers eintragen muss, also 192.168.1.1. 
Bei SuSE habe ich das mit YaST gemacht, hilft nichts. Bei Debian 
finde ich den Befehl nicht, um den Standard-Gateway zu ändern. 
ifconfig kann es nicht (nur die IP- und Broadcast-Adressen sowie 
Netzmaske), und auch andere ähnliche Programme scheinen dies nicht zu 
können (Es muss jedoch irgendwo sein, denn unter Knoppix gab es ein 
Tool, das ist aber bei der "Konversion" zu Debian verschwunden.

Der Befehl pppoe -A -I eth0 bringt die Info, dass ein 
"Access-Concentrator" gesucht und nicht gefunden wurde, und 
schlussendlich "Timeout waiting for PADO packets".

Die Hotlines von Tiscali und Draytek verstehen nichts von Linux und 
sagen "bei Windows geht es automatisch".

Ich vermute wie Robert, dass es auch einfach gehen sollte, finde aber 
den entscheidenden Dreh nicht. Sieht jemand von Euch, was ich falsch 
mache? Ist es überhaupt ein Linux-Problem, denn über den 
Internet-Explorer von Windows98SE auf Win4Lin habe ich genau dasselbe 
Verhaltung?

Theo Schmidt



More information about the Linux-support mailing list