[linux-support] Bericht und Probleme bei LTSP 5

Theo Schmidt sus2006 at bluewin.ch
Fri Sep 7 08:53:16 CEST 2007


Hallo zusammen,

Vorgestern war an einer Lehrer-Veranstaltung der erste Einsatz der 
WT/Linuxola/ch-open/LUGS LTSP Demo-Anlage, und zwar mit 5 Bildschirmen 
und 4 Thin Clients (zusätzliche 1-2 TC möglich). Transport geht noch so: 
Veloanhänger 40kg  + Tasche 6kg + Rucksack 10kg, geht alles mit 
Velo/Bus/Zug. Die vielen Kabel wiegen ziemlich. Beim Zusammenbau habe 
ich den Kabelsalat unterschätzt: es braucht schon einige Zeit, alles 
zusammenzustöpseln und es sieht unordentlich aus. Im Nachhinein hätte 
ich mich für eine Lösung mit Laptops entscheiden sollen.

Installiert ist Edubuntu 7.04 + KDE + XFCE + weitere LernSW. Ich habe 10 
User kreiert. (Das hat ziemlich gedauert, bis ich herausgefunden habe, 
welche Sachen nach /etc/skel zu kopieren sind, damit beim ersten User 
gemachte Arbeit bei den anderen auch dabei war.) An der Edubuntu 
LTSP-Konfiguration musste wegen den zwei Netzwerkkarten eine einzige 
Aenderung in /etc/default gemacht werden.

Drei Probleme:
1) Die Thin Clients starten weiterhin mit GDM, obwohl sonst für den 
Server der viel bessere KDM eingestellt ist. Ich habe die richtige 
Einstellung noch nicht gefunden, dies zu ändern.

2) Auch wenn's funktioniert geht das Booten sehr lange. Mit Kubuntu 
Dapper und LTSP 4.2 (unsere zwei Produktiv-Anlagen) geht das Booten 
schnell: nach dem Laden des Kernels kommt die übliche Meldung, dass die 
Grafikkarte nicht erkannt wurde, und dann startet X in wenigen Sekunden. 
Beim jetzigen System kommt nach dem Laden des Kernels die längste Zeit 
ein Edubuntu Splash-Screen und dann noch lange viele Textmeldungen bis X 
mit GDM endlich erscheint. Nach dem Einloggen geht es wieder sehr lange, 
bis die Oberfläche kommt, bei Dapper/LTSP4.2 geht das ein paar Sekunden.

3) Tatsächlich einen User zu starten ist reine Glücksache. Ich musste 
über 50 Versuche machen, bis ich endlich die 4 TC in Betrieb hatte. 
Teilweise sicher eine Frage eines falschen Passworts, wo sich GDM sehr 
"sicher" verhält: lange nichts, und dann wieder einfach GDM. (Bei KDM 
kommt bei einem falschen Passwort oder User sofort eine Fehlermendung, 
auch wenn Caps Lock gedrückt ist.) Es hat aber sicher nicht nur mit 
Passwörtern zu tun. Gnome und KDE liessen sich etwa gleich häufig 
starten (oder nicht).

Liefen sie, war es OK: sogar Ton und Video liefen ruckelfrei auf 
mehreren Thin Clients gleichzeitig (bei Total 1 GB RAM). Ich hatte keine 
Abstürze, allerdings hat sich aus den 150 oder so interessierten 
IT-Verantwortlichen für Schulen *kein Einziger* hingesetzt, um nur das 
geringste auszuprobieren, ein paar haben es immerhin angeschaut. Somit 
waren nie mehrere Leute an den TC.


Fazit:

Mechanisch: hier muss ich den Kabelsalat in den Begriff bekommen, z.B. 
mit einem vorgefertigten Kabelbaum. Eine andere Idee wäre es, auf die 
Tastaturen zu verzichten, da kaum jemand ernsthaft damit arbeitet, und 
lediglich eine virtuelle Tastatur anzubieten.

Software: so wie es jetzt ist, ist die Anlage brauchbar, aber eine 
Zumutung/Verschlimmbesserung (gegenüber LTSP4.2).

Ich hoffe, dass jemand von Euch an die OpenExpo in Oerlikon kommt und 
vielleicht an der Konfiguration arbeiten kann, mindestens die 
Einlog-Probleme müssten sich lösen lassen.


Viele Grüsse,
Theo Schmidt



More information about the Linux-support mailing list