[linux-support] Linux Neuinstallation bootet nicht

andre.mair andre.mair at bluewin.ch
Wed Feb 19 18:10:21 CET 2020


Hallo Theo,

schon kurios dass die sdb 30G gross ist, aber eine 227.6G Partition 
angeblich enthalten soll, die genau so gross ist, wie diejenige auf sda. 
Vielleicht wird die SSD zum Schnellstart benutzt, und eine Einstellung 
im BIOS verweist darauf (irgendeine "FastBoot"-Option die man auch 
ausschalten kann). Oder aber vielleicht ist genau dies ein Beispiel der 
Plattenkonstellation einer Hybrid-Festplatte, von der ich gelesen und 
geschrieben habe, aber noch nie damit zu tun hatte.

Falls nicht ausschaltbar, kann ich mir vorstellen, dass eine Umstellung 
auf (u)efi dies umgehen könnte, da der Startprozess dann eine 
efi-Partition suchen würde (Mutmassung..), und auf hd0 findet, wenn man 
sie dort installiert hat.

Warte noch auf eine Antwort von Markus, aber falls du Dies versuchen 
willst, hier wie ich es einmal gemacht hatte :

- Neue Partitionstabelle erstellen, gpt.
- efi-Partition 150M mit vfat-Formatierung und esp-flag, mountpoint 
/boot/efi eingeben
- Datenpartition mit ext4 und mountpoint /
- swap mit swap-flag, keine Formatierung (1xRAM-Grösse)

Die Möglichkeit dass esp-flag zu setzen wird einem glaub erst gegeben, 
nachdem die Partitionstabelle erstellt wurde und bevor sie dann 
endgültig geschrieben wird (mit gparted, dass vom Installationsvorgang 
gebraucht wird), aber weiss nicht mehr genau wie das war..

Ich würde in deinem Fall alles auf hd0 installieren (sda) und die sdb 
ungebraucht lassen.

Gruss, Andre


Am 19.02.20 um 14:38 schrieb Theo Schmidt:
> Vielen Dank Werner und auch Robert (für private Posts)!
>
> Am 19.02.2020 um 10:19 schrieb Markus Wernig:
>> Hallo Theo
> ...
>> Da werden aber auch Partitionen angezeigt, oder? Die Ausgabe ist also
>> von Porteus?
>
> Sorry, ein Durcheinander. Die Angabe war von lubuntu, welches die 
> Partitionen eben nicht sah.
>
> Mit Porteus hiess es:
>
> loop0-loop15 (lauter Loop-devices von Porteus)
> sda     465.8G disk
> |__sda1 227.6G part /mnt/sda1
> sdb  29.8G disk (ist ein SSD)
> |__sdb1 227.6G part
> sr0       7.8G rom  /mnt/sr0
>
> sdb ist ein 32 GB SSD. Ich versuchte es zu nutzen, installierte eine 
> Partitionstabelle (typ msdos) und eine Partition, konnte sie aber 
> nicht formatieren: "/dev/sdb1 is apparently in use by the system; will 
> not make a file system here!"
>
> Dann erschien irgendwann ein HP-Menu mit RAID-Einstellungen. Durch 
> "Remove acceleration" von sda wurde das RAID ausgeschaltet und da 
> ganze Windows Gedönz ist endlich weg. Aber alles andere auch. Ich 
> musste für sda eine neue Partitionstabelle machen (habe nun gpt 
> gewählt) und eine Partition erstellen und mit ext4 formatieren.
>
> Darauf habe ich Porteus v4.0 installiert inklusive Bootloader. Aber es 
> bootet immer noch nicht. Jetzt kommt: "Boot Device Not Found. Please 
> install an operating system on your hard disk. Hard Disk - (3F0)"
>
> Ich konnte Porteus von der DVD-ROM booten und sehe die Installation 
> auf sda1.
>
>
> Super Grub Disk meldet:
>
> No grub.cfg file detected
> No menu.lst file detected
> No core.img file detected
>
> (hd0) (hd0, gpt1)
> (hd1) (hd1, msdos1)
>
> Mit <enter> auf dem (hd0)-Eintrag kann ich das Porteus auf FP 
> tatsächlich booten. Aber wie komme ich zum Bootloader? (Die 
> Porteus-Website hat zwar einige Instruktionen, aber sehr komplizierte. 
> Das muss doch einfacher gehen?) War GPT die falsche Partitionstabelle?
>
> LG, Theo
>
>
>
>
>
>
> _______________________________________________
> Linux-support mailing list
> Linux-support at lugbe.ch
> https://maillists.lugbe.ch/mailman/listinfo/linux-support




More information about the Linux-support mailing list